Getting a P0603 code.

Aaron Dennis

SDD Junior Member
Joined
Mar 31, 2018
Messages
6
Reaction score
0
Location
Ohio
Hey all,

I have a 04 Ford F250 SD 6.0. I just completed the EGR delete.

Truck started up and ran ok for about 10 minutes. Idles really rough and then dies.
Hooked up a scan tool on it and it was throwing the P0603 Keep Alive Memory code.

Cleaned the connections on it just for S&Gs. Starts on its own sometimes, other times it won't.
I'm trying to figure out if it's the wiring or the PCM itself. I don't want to just keep throwing parts at the truck.
Any ideas? If its the wiring, which wire should I be testing?
 

bismic1

Full Access Member
Joined
Aug 3, 2008
Messages
219
Reaction score
19
Location
Texas
What are your ICP (psig and volts) and your IPR (% duty cycle) readings when cranking?

Are you getting Sync and FICM Sync when cranking?

RPMs when cranking?

Battery volts when cranking?

FICM MPower and LPower volts when cranking?

What are you using for a code reader (some readers do not read all the codes very well).

PCM's don't fail very often.
 

01yellerCobra

Full Access Member
Joined
Jul 18, 2015
Messages
434
Reaction score
86
Location
Cali
Did you check over the recent work and make sure everything is connected? Did you load a tune for the EGR delete? Does it need a tune for that?
 

bismic1

Full Access Member
Joined
Aug 3, 2008
Messages
219
Reaction score
19
Location
Texas
It doesn't seem like a priority issue to the OP ................
 

Members online

Forum statistics

Threads
30,520
Messages
266,081
Members
14,629
Latest member
Colvinecoboost14

Latest posts

Top