Help Needed help engine died

tommydawg

SDD Junior Member
Joined
Jun 11, 2008
Messages
8
Reaction score
0
Location
hemet calif
can any help me ,my 97 7.3 died last week I changed the fuel filter and cam sensor I pulled 2 fault codes p1211 and p1212 can anyone point me in the right direction Im pretty sure its a fuel deleverey problem I just cant pin point the problem. thanks :confused:
 

bbressler

Full Access Member
Joined
Nov 4, 2006
Messages
394
Reaction score
0
Location
Happy, TX
Those codes are related to the ICP, you don't happen to have the 10K mod, do you?? If you did, I'd try removing that and see if it's any better....or you may try replacing the ICP sensor.
 

bbressler

Full Access Member
Joined
Nov 4, 2006
Messages
394
Reaction score
0
Location
Happy, TX
Yup...

should be right behind the AC compressor.

Looking for a picture...
 

Paul H

SDD Junior Member
Joined
May 27, 2008
Messages
23
Reaction score
0
Location
Thronville, Ohio
Quick note.

The injectors need something above 500 psi to fire, If you have a bad ICP you can unplug it and try to start the engine. Seeing no ICP signal, the PCM will use a default setting of 750psi as a pass / fail pressure for the IPR.

It will throw a CEL but will start.

if it does not start, you may have an o-ring blown on the end of the IPR not allowing it to build injection pressure.
 
Last edited:

Members online

No members online now.

Forum statistics

Threads
30,523
Messages
266,087
Members
14,632
Latest member
Simmons Inaya
Top