Question Help!

Discussion in '6.9 & 7.3L IDI Discussion (Non PowerStroke)' started by phillipdellis8, Sep 5, 2019.

  1. phillipdellis8

    phillipdellis8 SDD Junior Member

    Age:
    44
    Messages:
    1
    Likes Received:
    0
    Joined:
    Sep 5, 2019
    Location:
    US
    Truck while driving down the hwy started running rough similar to running out of fuel...... Positive both tanks have fuel..stopped briefly and @idle truck is really idling terrible when resuming down the hwy just not up to par after a few minutes I stopped again and again @ idle truck really started running rough then died and will not start!

    Sent from my moto e5 cruise using Tapatalk
     
  2. tabdiesel

    tabdiesel SDD Junior Member

    Messages:
    23
    Likes Received:
    3
    Joined:
    May 22, 2008
    Location:
    Flower Mound, Texas
    Do you have around a 1/4 tank of fuel? Could be your "shower head" has fallen off of your fuel pump pick up. I'm in the process of that right now, can't let it get below 1/4 tank or she'll start sucking air.
     
  3. john mathis

    john mathis SDD Junior Member

    Messages:
    26
    Likes Received:
    2
    Joined:
    Nov 17, 2009
    Location:
    ramsey,il
    My 7.3 did the exact same thing a few years ago. I had a heat probe for an Edge box in one manifold and immediately started losing temp on that side. The wiring harness under the valve cover for that side that goes to the injectors had a connection that came apart. Very common problem and they run like $#:+ on 4 cylinders.
     
  4. Shaggy

    Shaggy Administrator Staff Member

    Age:
    43
    Messages:
    120
    Likes Received:
    8
    Joined:
    Aug 11, 2012
    Location:
    Arizona
    Get it figured out?
     

Share This Page