Help Needed ICP no power

Discussion in '6.0L PowerStroke Engine & Drivetrain' started by starduster, May 26, 2020.

  1. starduster

    starduster SDD Junior Member

    Messages:
    29
    Likes Received:
    1
    Joined:
    May 9, 2011
    Location:
    Santa Cruz,CA
    2005 F-250 6.0 runs very rough has no power like it use to. I have the Edge CTS monitoring system
    on there and the ICPv reads 0 and of course with that value the ICPpsi reads 870 (which we know is false). The codes it was reading are 2285,2286,2287. After replacing the ICP and pigtail (yes the new pigtail is wired correctly) I am getting the same codes and 0v at the ICP. I have inspected the harness and all connections to all I could see, so now I am thinking I need to break out the voltage meter and start checking things myself. I am thinking that I should verify the integrity of the main harness. Any suggestions would be greatly appreciated.
     
  2. bismic1

    bismic1 Full Access Member

    Messages:
    162
    Likes Received:
    6
    Joined:
    Aug 3, 2008
    Location:
    Texas
    To help in your troubleshooting ......

    FOR 05 and UP - With the ICP connector facing away from you (looking at the back of the connector) and the connector lock tab down:

    The wire on top is a sensor monitor or signal wire (dark blue / light green) - goes to PCM connector C1381C (center plug), pin 29

    The wire on the left is the signal return to the PCM (grey / red) - goes to PCM connector C1381a (center plug), pin 33

    The wire on the right is the 5 volt V-reference power to sensors (brown / white) - goes to PCM connector C1381a (center plug), pin 45

    Also as a reference - the ICP connector number is C1244
     
  3. starduster

    starduster SDD Junior Member

    Messages:
    29
    Likes Received:
    1
    Joined:
    May 9, 2011
    Location:
    Santa Cruz,CA
    Thank You, I just now visually inspected the harness for chaffing, other than being a little on the brittle side it appeared to be ok.
    I will put my meter on those wires this afternoon, Thanks again.
     
    bismic1 likes this.
  4. bismic1

    bismic1 Full Access Member

    Messages:
    162
    Likes Received:
    6
    Joined:
    Aug 3, 2008
    Location:
    Texas
    I wonder what that meter had to say .......
     

Share This Page