Question stock trans temp gauge

chris o.

SDD Junior Member
Joined
Jul 20, 2008
Messages
39
Reaction score
0
Location
henderson, nv
the stock trans temp gauge goes to the middle when the key is on but truck is cold... the gauge doesnt move after truck is warm. key is off and it goes down, turn key on and it goes half way. any ideas? location of sending unit?

thanks
 

aklim

Full Access Member
Joined
Oct 15, 2006
Messages
243
Reaction score
0
Location
Hartford, WI USA
Forget it and get an aftermarket unit. Remember, Ford is the one that gave you the idiot light oil pressure gauge. As long as you have 5 psi, it reads normal. Do you want to tell me that you think 5 psi is fine for me if I run at 3000 rpm?
 

yukondiesel

Full Access Member
Joined
Jun 17, 2008
Messages
80
Reaction score
0
Location
Flanders, NJ
I kind of agree with aklim...Get it fixed by Ford (under Warranty?) and get a set of guages too. Especially the oil pressure! WOW! I didn't know the oil pressure light was THAT bad!
 

aklim

Full Access Member
Joined
Oct 15, 2006
Messages
243
Reaction score
0
Location
Hartford, WI USA
I kind of agree with aklim...Get it fixed by Ford (under Warranty?) and get a set of guages too. Especially the oil pressure! WOW! I didn't know the oil pressure light was THAT bad!

The oil pressure light was designed to keep the driver calm. On my GM, it would rise up and then settle to a certain pressure and go up when it is revved and drop down to that pressure when it is not. Ford didn't want you to get worried so they made it such that when you get 5 psi, the gauge reads normal. Still you get to see the gauge instead of an idiot light that shows up when the pressure is low so you think you have something. Ever notice it doesn't move up no matter what you do?
 

chris o.

SDD Junior Member
Joined
Jul 20, 2008
Messages
39
Reaction score
0
Location
henderson, nv
yeah i know how to do it the right way, i just dont like having this nice of a truck and some things dont work. out of warranty. any one know where the stock sending unit is?

Thanks,
Chris O.
 

fgtex

Full Access Member
Joined
Dec 28, 2005
Messages
279
Reaction score
0
Location
Little Elm, TX
The stock gauge is junk. My aftermarket trans gauge can show less than 100* and the stock gauge on the dash shows to be in the mid-range.

It doesn't sound like there is anything to fix. Are you having trans problems? The trans temp function that you are describing sounds normal.
 
Last edited:

Members online

No members online now.

Forum statistics

Threads
30,506
Messages
266,042
Members
14,618
Latest member
Kastn4
Top