Turbo Problem...Need Help!

00javelin

SDD Junior Member
Joined
Apr 7, 2011
Messages
8
Reaction score
0
Location
Tuscaloosa, AL
So here's the deal. Last weekend my truck started acting weird. Had a little of what felt like a miss at about 70 mph around 2000 Rpm. However, no ck engine light. The next day I noticed the turbo would lag badly. I cleaned the EGR valve and that didn't really help. I assumed the vanes were sticking and took her out on the interstate and let her rip. This seemed to clear it up for a little while. On monday, after the temp warmed up outside, I began to get nothing from the turbo except when I held my foot in it at at around 3000 it would turn loose and boost on up. The turbo seemed not to be spinning at all. Again...Truck running fine otherwise...Guages ok and no ck engine light! I took it to the local shop which specializes in the 6.0 on tue. Was cold here on tue morning and it ran fine while I was taking it over there. They drove it for over an hour and it ran fine...Was able to get a low boost code 1 time while running it, but otherwise ran perfect. I picked it up yesterday and it ran fine on the way back to work...again the temp outside was in the 50's. After work when 75 outside it starts doing the same thing again. It is like the turbo is dead and will eventually break free and boost. When this is going on, I can not hear it at idle like I usually can. I have been told that the bearligs may be trying to seize. The thing that puzzles me is what the air temp may have to do with this situation. Thanks in advance! Truck is 05 - 6.0 no mods 172K
 

BIG JOE

Full Access Member
Joined
Apr 6, 2005
Messages
5,423
Reaction score
55
Location
CenCal
By what you've described.. I don't think the outside temps really have anything to do with it. They are just coincidental. I'm thinking the Turbo is on it's way out. Or the vanes are dirty with crud. The 6.0 turbo's are known for that (?).

Anyone else ? 6.0 guyz ?

OBTW.. WELCOME TO SDD ;tu

Yul get some-more opinions here.. PDQ.

Joe
 
Last edited:

Dogman

Full Access Member
Joined
Nov 19, 2007
Messages
1,789
Reaction score
2
Location
tampa,FL
When cool take the cold air tube off at the turbo and use your finger to see if the turbo is moving freely. It should spend really EZ also check and see if there is any up and down movement in the shaft. It may need to be torn down and cleaned.
 

00javelin

SDD Junior Member
Joined
Apr 7, 2011
Messages
8
Reaction score
0
Location
Tuscaloosa, AL
When cool take the cold air tube off at the turbo and use your finger to see if the turbo is moving freely. It should spend really EZ also check and see if there is any up and down movement in the shaft. It may need to be torn down and cleaned.

The cold air tube is the one coming from the air box, Right?
 

Yooper75

Boost Junky
Joined
Oct 12, 2007
Messages
331
Reaction score
1
Location
Michigans Upper Pennisula
The vanes are either caked with soot and crud or your unison ring is shot. Your truck has about the same milage when my turbo gave up on my 06 and had to be replaced.
 

Members online

No members online now.

Forum statistics

Threads
30,520
Messages
266,081
Members
14,629
Latest member
Colvinecoboost14

Latest posts

Top