Wrench Light came on

Discussion in '6.4L PowerStroke Power & Performance' started by MB Dave, Dec 21, 2011.

  1. MB Dave

    MB Dave SDD Junior Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Jul 28, 2011
    Location:
    Park Ridge IL
    So a wrench light came on, the car drives like poop! The symptoms: no power, sounds real rough, rough idle, when you rev it at w.o.t it stops at 2100rpm and sounds like it hitting a a rev limiter. After a second of so it revs to redline with a cloud of white smoke.

    Could be something simple like fuel filters?

    Can anyone recommend a mechanic/ or a shop in the Chicago-land area
     
  2. ducky1402

    ducky1402 member

    Messages:
    101
    Likes Received:
    0
    Joined:
    Jun 11, 2010
    Location:
    AZ
    has it completly regened lately? sounds like reduced power mode from regen issues maybe.........
     
  3. MB Dave

    MB Dave SDD Junior Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Jul 28, 2011
    Location:
    Park Ridge IL
    It regens about every fill up.
     
  4. jetallman

    jetallman Full Access Member

    Messages:
    52
    Likes Received:
    0
    Joined:
    May 30, 2011
    Location:
    Hannibal missouri
    my 05 has this problem when pulling, if you stop and turn off the engine and wait for a minute it resets itself and is fine. This usually happens once in a long trip usually when the boost is up high, I learned to just pull over and live with it. The fuel system is going into emergency mode according to my owners manual
     
  5. Tbone

    Tbone SDD Junior Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Jan 8, 2012
    Location:
    Pendleton OR
    We have an 08 that has the same problem we were told by ford dealer that the fuel filter is pluged. We changed both bleed the system and we still have the same problem. When we pull the trailer hard up hill it will drop the power you stop shut it down to reset and away you go agine we are currently working on this ourself soon as we find the problem i will post it. mean time let me know if any of you have the same problem :dunno
     
  6. jetallman

    jetallman Full Access Member

    Messages:
    52
    Likes Received:
    0
    Joined:
    May 30, 2011
    Location:
    Hannibal missouri
    Any updates on this thread?
     
  7. LEEthal75

    LEEthal75 SDD Junior Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Apr 17, 2010
    Location:
    Galveston County, Texas
    Same issue here. At least once or twice a trip when I'm pulling my 31' boat, I have to pull to the shoulder of the road due to this very issue. VERY UNSAFE!

    I'm considering EGR delete since several of my buddy's have same vehicle, have done the delete and have no problems.
     
  8. jpringle83

    jpringle83 Full Access Member

    Messages:
    170
    Likes Received:
    0
    Joined:
    Feb 20, 2007
    Location:
    WA
    Interesting this just started happening on my '05 wrench light comes on truck enters limp mode pull dtc's from tuner and get nothing. Pull over shut truck off restart and continue on my way. Only happens when pulling the 5th wheel which is usually around 14k.
     
  9. Tbone

    Tbone SDD Junior Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Jan 8, 2012
    Location:
    Pendleton OR
    Wrench light

    Yes i pull a training trailer with not a lot of weight but about 3k LBS this is jsut driving the truck i let off to slow down to go around a corner and soon as i mash the peddle after the corner it drops of and goes into limp mode. and yes the only way to fix it is pull over turn it off and then start over i have also done that while pulling and then continue up the hill and it does the same thing imediatly. some times it has to be shut down for a few to reset it seems.
     
  10. Tbone

    Tbone SDD Junior Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Jan 8, 2012
    Location:
    Pendleton OR
    Wrench light

    We put a regen delet pipe and tune on it so at 2 am when im headed back from call for the fire department i dont have to drive the dam thing all night to reset it. the good thing the power is great and at least one to two miles per gallon better milage with the kit delet. Im sure if you were traveling down the road it would make even better milage.
    Oh ya we have about 50K on it and it get oil changes by the hour because of the extream amount of idleing it gets on scene.
     
    Last edited: Mar 14, 2012

Share This Page