Finishing trans install question

Discussion in '99+ 7.3L PowerStroke Engine & Drivetrain' started by dboyw, Feb 22, 2012.

  1. dboyw

    dboyw Full Access Member

    Messages:
    358
    Likes Received:
    0
    Joined:
    Aug 30, 2005
    Location:
    Lancaster, PA
    I am finishing up the install of a BTS trans. Installed a new flexplate also. Filled the trans with fluid according to Brain, and added more once truck was started. I have a screeching noise when the truck is in gear, but wheels not turning. Does not seem to happen when truck is in park.

    Could this be the torque converter just not full of fluid yet? Brian's direction say to not remove the TQ when installing the trans so I was unable to fill prior to install.

    I have a call into Brian but was just looking for some advice here.

    Thanks
     
  2. WD40

    WD40 Full Access Member

    Messages:
    3,455
    Likes Received:
    17
    Joined:
    Aug 23, 2005
    Location:
    Benton Arkansas
    What did you find out, are you up and running now? Sure hope so.
    Doug
     
  3. JLDickmon

    JLDickmon ursus combibo

    Messages:
    4,171
    Likes Received:
    12
    Joined:
    Jun 22, 2006
    Location:
    49041
    flex plate hitting inspection cover?
     
  4. dboyw

    dboyw Full Access Member

    Messages:
    358
    Likes Received:
    0
    Joined:
    Aug 30, 2005
    Location:
    Lancaster, PA
    Went out this morning and rechecked everything. I could not find any rubbing anywhere. Was able to spin the flex plate with torque converter attached and could not feel or hear any rubbing. Started truck up and the noise was gone. Shifted to the different settings (R,N,D,2,1) and let off the brake. Wheels spun and no noise.

    Took her out for a quick spin and could here it every once in a while but not like it was. Will keep an eye and ear open for anything.

    The truck feels different now. Have not driven since November of '11. Need to feel her out again. I do realize that the new trans will make it feel different, just need to get the feel of her. I will wait awhile, thinking a month, until I turn the DP Tuner chip from stock setting.

    Thank you to everyone that has helped in any way with this latest project of mine.
     

Share This Page