Help help help something wrong with my new diesel 2000 F-350

Discussion in '99+ 7.3L PowerStroke Engine & Drivetrain' started by Hawkeye Deadshot, Jan 29, 2018.

  1. Hawkeye Deadshot

    Hawkeye Deadshot SDD Junior Member

    Messages:
    17
    Likes Received:
    2
    Joined:
    Jan 17, 2018
    Location:
    Columbia, South Carolina
    I have a 2000 7.3 L Powerstroke turbo four wheel drive crew cab and something is wrong this morning when I started it any help appreciated

    Something bad happened, airbag, abs lights on, speed not working, and overdrive light flashing

    I did have water in the passenger side air vent it's been raining all day yesterday I'm not sure where the water got in the vent at


    Ruining ok though
     
  2. 01yellerCobra

    01yellerCobra Full Access Member

    Messages:
    366
    Likes Received:
    73
    Joined:
    Jul 18, 2015
    Location:
    San Diego
    Is that the generation with the GEM under the windshield? It sounds like something got wet that shouldn't be wet.

    Misspelling brought to you by Tapatalk
     
  3. JLDickmon

    JLDickmon ursus combibo

    Messages:
    4,164
    Likes Received:
    10
    Joined:
    Jun 22, 2006
    Location:
    49041
    ABS, speedo & overdrive flashing might come down to a problem with the sensor in the pumpkin. I've also seen a lot of wires break inside the insulation at the connector (I think my truck has this malady right now).

    But if it did NOT do it before it rained, I agree with the post above this one. Likely the windshield leaks and water has gotten in to the GEM module.
     
  4. Hippy

    Hippy SDD Junior Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Apr 20, 2016
    Location:
    Atlantic Pa.
    That is a common issue with all of the Ford Tks. Windshield leaking . Have the windshield resealed even if you can't see where it is coming in . It only gets worst. I have had the lights, radio and heater motor start running in the middle of the night.
     
  5. TwinTop

    TwinTop SDD Junior Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Oct 1, 2015
    Location:
    Kaysville, UT
    If you've got running lights on the top of your cab check them also as a source of water getting on the GEM module.
     
  6. Hawkeye Deadshot

    Hawkeye Deadshot SDD Junior Member

    Messages:
    17
    Likes Received:
    2
    Joined:
    Jan 17, 2018
    Location:
    Columbia, South Carolina
    Replaced the windshield and problem went away.... It was water....
     
  7. predatorproblems

    predatorproblems SDD Junior Member

    Age:
    49
    Messages:
    16
    Likes Received:
    2
    Joined:
    Jun 29, 2017
    Location:
    Central Texas
    Mine did the same thing. Seal the windshield and dry it out. You should be good to go.


    Sent from my iPhone using Tapatalk
     

Share This Page