Help Needed Please help!

Discussion in '6.4L PowerStroke Engine & Drivetrain' started by Roccafellas, May 7, 2017.

  1. 01yellerCobra

    01yellerCobra Full Access Member

    Messages:
    230
    Likes Received:
    51
    Joined:
    Jul 18, 2015
    Location:
    San Diego
    Well, the oil light could be from the engine shutting down. Unless you're positive it came on before the engine stopped spinning. If you are check the oil and coolant. If you have a milkshake something is hurt. If you don't it's time to start hunting. But given your speed and how it shut down I'm guessing something got hurt.

    Misspelling brought to you by Tapatalk
     
    Last edited: Jun 20, 2017
  2. Roccafellas

    Roccafellas SDD Junior Member

    Age:
    23
    Messages:
    11
    Likes Received:
    0
    Joined:
    May 7, 2017
    Location:
    Sudbury ontario canada
    No milkshake oil light came on after


    Sent from my iPhone using Tapatalk
     
  3. Roccafellas

    Roccafellas SDD Junior Member

    Age:
    23
    Messages:
    11
    Likes Received:
    0
    Joined:
    May 7, 2017
    Location:
    Sudbury ontario canada
    Im so stressed


    Sent from my iPhone using Tapatalk
     
  4. 01yellerCobra

    01yellerCobra Full Access Member

    Messages:
    230
    Likes Received:
    51
    Joined:
    Jul 18, 2015
    Location:
    San Diego
    My next step would be a compression check. Check the glow plugs for any damage.

    Misspelling brought to you by Tapatalk
     
  5. Roccafellas

    Roccafellas SDD Junior Member

    Age:
    23
    Messages:
    11
    Likes Received:
    0
    Joined:
    May 7, 2017
    Location:
    Sudbury ontario canada
    Just heard back from the shop its at they think its a cooked turbo! It started and ran apparently like a bag of shit
    But ran lol
    Thank you all for the advice and feedback i truly appreciate it if any of you guys are in canada ontario, and need bodywork and paint let me know ill lend a hand!


    Sent from my iPhone using Tapatalk
     
  6. 01yellerCobra

    01yellerCobra Full Access Member

    Messages:
    230
    Likes Received:
    51
    Joined:
    Jul 18, 2015
    Location:
    San Diego
    In the grand scheme of things that's not too bad. If you don't have any gauges this might be a good hint to get some.

    Too bad you're so far. I could use help on my Cobras back bumper.

    Misspelling brought to you by Tapatalk
     
  7. troutwest66

    troutwest66 6.0- The Dark Side!

    Messages:
    159
    Likes Received:
    14
    Joined:
    Apr 5, 2005
    Location:
    Post Falls, Idaho
    I assume your speed was in kph and not mph? Good luck with it.
     
  8. Roccafellas

    Roccafellas SDD Junior Member

    Age:
    23
    Messages:
    11
    Likes Received:
    0
    Joined:
    May 7, 2017
    Location:
    Sudbury ontario canada
    Yeah kmh and i hope its just the turbos


    Sent from my iPhone using Tapatalk
     
  9. Roccafellas

    Roccafellas SDD Junior Member

    Age:
    23
    Messages:
    11
    Likes Received:
    0
    Joined:
    May 7, 2017
    Location:
    Sudbury ontario canada
    [​IMG]

    There's the truck.. let me give you some background on it too maybe it will help my case.. it's an 08 F-250 Job 1 FX4 i think.. i can't tell what trim. I just know the colour and wheel package signifies a trim as I've seen it on other super duties.. anyways it has 300,000 kilometres and when I showed up it had a reduced engine power light.
    I pulled these codes
    P0088
    P2002
    C1233
    P244A
    And P2452

    I checked for blowby
    There was some.. i put the cap on the fill cap it could NOT levitate it.. i Checked the oil it was FULL and black.. i checked coolant it was red/orange and low. Under low fill mark. Where the Mold line is..
    i cleared the codes
    He told me it had an exhaust on it with stacks that i still have sitting in the box but not hooked up.. and that it came from alberta and that he got it and got pulled over by the ministry of environment. And they told him to put a proper exhaust on so he got one put on it has a cat and dpf but aparently he said it is clogged says his mechanic.. thats why it ran like that. In reduced power mode.. so I know somebody had to of tuned the truck because im sure the guy didnt have the dpf on with stacks but maybe he did anyways it also has a afe stage 2 that is in horrible shape the boot connecting to the turbo fell apart when i undid it to check shaft play
    And the filter was absolutely clogged i mean filthy so i took it off cleared the codes
    Reduced engine power was gone I cleaned the filter as much as i could put it on and went for a rip and I basically fixed it infront of him. poor guy didnt know much.. so i got him from $10K to $4500.00
    DROVE IT NO PROBLEMS 4.5 hours home! On a super hot day
    Passed a few cars too! Like I got on it and thankfully it didnt blow but i never went past 100 because i couldnt there was a nasty vibration i figured ujoint.. so now im home and i bring the truck to get certified.. it needs a Left front wheel bearing and u joint and pinion seal both at the front diff
    And the kicker is no wonder it would shake at 100 i was stuck in 4x4 i couldnt tell honestly and im not an idiot
    It didnt crab walk i had wheels in full lock it drove as if it was in two wheel and i wasnt a hot head and never squealed the tires so i couldnt of "found out the hard way" anyways. He fixed it. It's certified
    That night literally 6 days after i got the truck. I was driving home wanted to see if it still shook at 130.. so I pick it up from the mechanic (keep in mind ive had it for 6 days been driving it around here and there and reduced engine power never came back on) well i pick it up and i go to turn onto the street and it comes back on.. i get worried go to my friends i got p2452 and thats it.. if i remember.. clear it
    drives fine
    But now as I give light throttle theres a good amount of lag and blueish whiteish smoke and black smoke coming out
    Sometimes black
    Sometimes the other colours.
    My buddy called me i last him in traffic and he said what kind of tune you have i said stock.. he said no way because he owns sudbury custom auto and he had 2 6.4s and stock he said they wouldnt even puff and i will admit if i got on it
    It would cough a small puff..
    But i never thought about it
    I was hoping someone didnt leave this truck with a tune.
    Anyways
    I continue on my journey now with my girlfriend finally on the way home her first time! IN THE TRUCK! How embarrassing..
    Anyways so im doing like 100 i got on it full throttle
    (Yes stupid me)
    (Why would you...-I don't know i'm an idiot i get it it was hurt to begin with)
    Those are my flaws.
    Anyways
    I felt a horrible shake
    My girlfriend said pull over we smelled a burning smell not bad but worried me too..
    I look down at the gauge its lit up the rpms at 0 the truck died.. i coast maybe 100m to a stop. Keep in mind i was driving and i wasnt looking at the gauges and when it died when i finallt looked down and said "oh ****" i realized the truck was still in D so i got worried thinking my engines turning with no oil so i slap it into N come to a stop
    Try and start it
    And it starts like i said like that black ford on youtube when he did a burnout and killed the truck.. "title is powerstroke blows up" if you want to referance
    I MEAN EXACTLY how it started.

    But like i said
    Never spewed coolant
    And no white smoke
    Just minor smoke from the oil puddle i saw under the turbo and running down the oil fill cap.. i thought the engine puked and sent oil through the ccv or pcv into the intake to the turbo.. because when i pulled the intake off again. Thats when the boot fell apart in my hand (previously stated i said i took the boot off and it crumbled i was talking about now. When i first got the truck i took off the filter only to try and start it i hadnt taken the whole tube off but i did see how gross the boots looked then) anyways i pulled the intake off there was a film of oil in the intake
    And in the intake box where the filter sits a little puddle and in the inlet of turbo
    It has shaft play for sure. Not like a knife through butter tho just up and down.. oil running down the passenger side of the block.
    I looked at the coolant bottle it was bubbling.. so i tried to start it again and same thing
    Slow turn over
    Anyways my buddy showed up with a scanner then and i frieken forget what the codes were! Im so upset i didnt write them down.. and he cleared them thinking it would start we even had a booster pack to it. so i figured i seized or hydrolocked it or a piston was dragging so fortunately where it died there was a diesel service center for big rigs mostly. I left it there
    And then a couple days after i call to check and the guy says he thinks the turbo blew and that theres no oil pressure i said how do you think theres no oil pressure he said i looked at the gauge on the dash. Obviously he didnt know its a tranny temp gauge..
    anyways so they have yet to really hook up a scanner and do a good diagnostic i had a good chat with the owner hes cool and hes going to look at it personally when he has a minute its been two weeks but im not rushing we hit it off and hopefully he can help
    Apparently hes awesome at scanning and electrical and diagnosing with computers.. but his guy said he got it started no booster pack no nothing it turned over moderately and started no power when he pressed the gas and then it died and wouldnt start again
    Thats where im at the last ive heard
    Now hopefully you all get the jist that im just an average guy trying to get his truck back and running
    I have the new turbo if its gone
    The egr delete exhaust DP tuner everything
    Just waiting to hear from them what i messed up
    I looked at the coolant again last night the shops not far from my house i like to visit lol
    The coolant seemed lower
    Still not milky tho at all
    Didnt see any dirt
    Oils black
    And i dont see any new leaks
    But i didnt attempt starting it


    Sent from my iPhone using Tapatalk


    Sent from my iPhone using Tapatalk
     
  10. troutwest66

    troutwest66 6.0- The Dark Side!

    Messages:
    159
    Likes Received:
    14
    Joined:
    Apr 5, 2005
    Location:
    Post Falls, Idaho
    Updates??
     

Share This Page