surging idle/ stalls when stopping

mike avery

SDD Junior Member
Joined
Jul 21, 2020
Messages
6
Reaction score
2
Location
Connecticut USA
Ok so I have a 97 7.3 with 118,000 miles. Problem I’m having is surging idle after it runs for a few minutes and it wants to stall when coming to a stop or letting off the accelerator when driving. All new glow plugs, new fuel filter, new in tank pickup tube, new gpr, new cam/crank sensor, new valve cover gaskets, new ipr, fuel pressure at 50psi at idle. I have autoenginuity and everything looks normal from all the reading and no codes. When shifted into neutral I can keep it from stalling but still wants to stall when coming down from higher rpm and doesn’t want to idle up. Thought torque converter at first until the bad idle now thinking a failing lift pump. Oil is new and full. I should add the history of the truck, I got it recently and it ran poorly. I discovered someone had removed the fpr spring and valve for some reason, I’ve since put one back in but still have the same issues. Also I replaced the idm which seemed to help as the surging wasn’t a 500rpm surge and now is just 50-100rpm. I also changed the pcm because the windshield gasket had gone and it leaked water all over it. Unplugging icp makes no change. I’ve also checked the ebp tube which there was no clog. What’s everyone else think? cant attach a .csv file so cant post my log data Thanks in advance
 

erikf

SDD Junior Member
Joined
Nov 6, 2014
Messages
4
Reaction score
0
Location
United States
I read something else here about an aftermarket cam/crank sensor causing interference to some electronic parts. It sounded odd to me but I guess it's a known issue. The other poster replaced with a motocraft / Ford factory part and the issue went away.
 

Staff online

Members online

Forum statistics

Threads
30,506
Messages
266,042
Members
14,618
Latest member
Kastn4
Top