Question What's Wrong with my Blower Motor

Discussion in 'Mobile Audio/Video & Electronics' started by diesel4camping, Dec 19, 2010.

  1. diesel4camping

    diesel4camping SDD Junior Member

    Messages:
    39
    Likes Received:
    0
    Joined:
    Apr 30, 2008
    Location:
    Huntington, WV
    Didn't check if it was high only, but I did plug it all back together and no problems now. All speeds work and no fading of the rpm's when turning to the right.

    I guess I'll wait to see when it happens again and then start replacing parts.
     
  2. NevrKnow

    NevrKnow Full Access Member

    Messages:
    401
    Likes Received:
    0
    Joined:
    Mar 23, 2009
    Location:
    Aiken,SC
    Great thread. Been reading it along the way, went out today, and damm if mine didn't start to blow ALOT slower. Least i know now what to start checking. Thanks guys.
     
  3. bigrigr

    bigrigr Real trks hv 3 pdls

    Messages:
    372
    Likes Received:
    0
    Joined:
    Dec 1, 2008
    Location:
    provo, utah
    Sounds like you were dealing with the right connector, it may not be the resistor, but it sure sounds like it changed your symptoms. Maybe that connector just needs to be cleaned like Big Joe stated above.
     
  4. Kaimi K Kekahuna

    Kaimi K Kekahuna SDD Junior Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Oct 22, 2018
    Location:
    Hawaii
    Found this thread after installing my upfitter switches into my 2005 F250 superduty last night, I found my blower motor only has low setting. I will Respond when I get a chance to look at it.

    K
     

Share This Page