Won't start strange symptoms??

BobGrady

SDD Junior Member
Joined
Jun 1, 2010
Messages
2
Reaction score
0
Location
Blythe, Ca
3 weeks ago my I started my truck as normal. It ran for about 1/2 second and died. Idiot lights work on dash as normal, but dead. When I tried restarting it was dead. Dash lights came on but no crank or click or anything.

After letting it sit for a couple of hours... I tried to start it. It started but the starter stayed engaged. I shut it off. After that it started and ran okay.

2 weeks ago it did the same thing. Start, died, then nothing. After letting it sit... same thing started but starter stayed engaged until I shut it down. Then normal.

Took it to dealer who kept it over a week. They replaced a high pressure pump and said they found a short to the fuel pump. Assured me this fit the symptoms and was now fixed.

Today It started, ran about 1/2 second and died...gonna try again in a while.

Before the 2 1/2 hour drive to dealer, Any ideas?
 

iracemine

black and tan
Joined
Dec 10, 2006
Messages
958
Reaction score
0
Location
Cheese Curtain
Doesent this engine suffer from hydro lock problems? And because of that the starters get damaged (since the coolant poors into cylinder 8 after the engine is shut off)? Maybe your truck is having the start of this. Like its slowly starting to happen. Have your dealer check the compression on all 8 cylinders :dunno
 

Members online

No members online now.

Forum statistics

Threads
30,525
Messages
266,089
Members
14,634
Latest member
BLUKAS
Top