Won't start

Discussion in '911 Diesel Down! (Post only if your rig is broke)' started by John, Mar 2, 2019.

  1. John

    John SDD Junior Member

    Messages:
    8
    Likes Received:
    1
    Joined:
    May 27, 2016
    Location:
    Upstate NY
    08 6.4L won't start as tittle says. Was driving home when truck shuddered, immediate thought was it was about to gell up on me. Shuddered again 10 seconds later, this time I noticed the shift indicator light flash while it was shuddering. Stopped at neighbors house leaving truck running, drove 100 yards home truck sounded like it didn't want to shift, was reving high, but short run didn't think much of it. Parked the truck, as I was shutting it off, noticed shift indicator light was out. I then tried to restart the truck, nothing....

    Next day went to move truck to clear snow, fired up. Moved it noticed shift indicator light out again. Left it running, moved back to parking spot after clearing snow. Shut down, would not restart.

    Now trying to T/S, everything seems to work, glow plugs, radio, heater fan, etc except it wont crank, just hear a relay click.

    Looking for some input before I crawl through the snowbank to get under it. Thinking neutral safety switch or tranny module.

    Any thoughts or ideas welcomed.

    Thanks
     
  2. 01yellerCobra

    01yellerCobra Full Access Member

    Messages:
    359
    Likes Received:
    73
    Joined:
    Jul 18, 2015
    Location:
    San Diego
    The neutral safety switch wouldn't affect the truck while it was driving though. At least I wouldn't think so. Is the theft light blinking really fast when you try to crank it?
     
  3. John

    John SDD Junior Member

    Messages:
    8
    Likes Received:
    1
    Joined:
    May 27, 2016
    Location:
    Upstate NY
    No flashing light, dash looks normal when you turn the key to crank, just no cranking.
    I did get the truck started by jumping the relay under the hood, so now I can at least try to get it somewhere out of the cold.
    Haven't driven it yet though.
     
  4. John

    John SDD Junior Member

    Messages:
    8
    Likes Received:
    1
    Joined:
    May 27, 2016
    Location:
    Upstate NY
    SOLVED! Found 2 ground wires sticking out of the harness at the TCU, lugs rotted off. Crimped on new connectors and good to go.
     
    i-Henry likes this.

Share This Page