05 hiccup /stutter

Discussion in '6.0L PowerStroke Engine & Drivetrain' started by michael_maloney, May 15, 2019.

  1. michael_maloney

    michael_maloney SDD Junior Member

    Age:
    56
    Messages:
    5
    Likes Received:
    2
    Joined:
    May 15, 2019
    Location:
    US
    05 F350, bottom line, the engine cuts-out for about a half second, completely randomly. So when at RPMs it's just a stutter, at idle it's a stall. After the cut-out, the injectors rattle, like a fresh start. Which component is the one that actually rattles the injectors?

    Replaced the ICP sensor (it tested bad) ICP is good, replaced the cam position sensor. A bunch of other stuff is fresh, less than 10000 miles on HPOP, IPR, injectors. FICM voltages are good 13ish in 46.5 to 48 out. Fuel pressure 60lbs.

    Any ideas?

    Sent from my Moto Z2 using Tapatalk

    Sent from my Moto Z2 using Tapatalk
     
  2. troutwest66

    troutwest66 6.0- The Dark Side!

    Messages:
    207
    Likes Received:
    26
    Joined:
    Apr 5, 2005
    Location:
    Post Falls, Idaho
    Have you had it scanned ? Have to start there.
     
  3. snicklas

    snicklas Super Moderator Staff Member

    Age:
    45
    Messages:
    404
    Likes Received:
    21
    Joined:
    Aug 10, 2008
    Location:
    Greenfield, Indiana
    With the injector buzz again, the FICM or PCM is loosing power momentarily. When it gets power again, it runs the inductive heating sequence. It thinks the key has been turned off and back on.
     
  4. michael_maloney

    michael_maloney SDD Junior Member

    Age:
    56
    Messages:
    5
    Likes Received:
    2
    Joined:
    May 15, 2019
    Location:
    US
    Oh yeah, no codes.
     
    troutwest66 likes this.
  5. michael_maloney

    michael_maloney SDD Junior Member

    Age:
    56
    Messages:
    5
    Likes Received:
    2
    Joined:
    May 15, 2019
    Location:
    US
    That makes sense. After I posted, I pulled the FICM that I payed a shop to replace awhile back. All the tabs were broken off the plugs and they had put a piece of heater hose between the valve cover and the plugs presumably to hold them in. So gonna start with replacing the harness and see where it goes from there. Thanks.
     
    troutwest66 likes this.
  6. troutwest66

    troutwest66 6.0- The Dark Side!

    Messages:
    207
    Likes Received:
    26
    Joined:
    Apr 5, 2005
    Location:
    Post Falls, Idaho
    Did you get a chance to replace that harness yet?
     
  7. Steve_in_29

    Steve_in_29 SDD Junior Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Mar 6, 2006
    Location:
    29 Palms, CA
    There are replacement connectors available that you de-pin the old ones and replace them with.
     
  8. michael_maloney

    michael_maloney SDD Junior Member

    Age:
    56
    Messages:
    5
    Likes Received:
    2
    Joined:
    May 15, 2019
    Location:
    US
    All I've done so far is stare at it haha. I've heard of the replacement plugs, I don't relish the thought stickin all those little wires in holes, but I'm gonna try it.

    Sent from my Moto Z (2) using Tapatalk
     
  9. michael_maloney

    michael_maloney SDD Junior Member

    Age:
    56
    Messages:
    5
    Likes Received:
    2
    Joined:
    May 15, 2019
    Location:
    US
    Update- I haven't even messed with the plugs, bought a $200 FICM from one of those online places. I could tell that was it before I even started it, the injector buzz was strong and smooth, not like a rattle. Runs great. We'll see for how long.

    Sent from my Moto Z (2) using Tapatalk
     

Share This Page