Talk about the 7.3L CPS Here!

Discussion in '99+ 7.3L PowerStroke Engine & Drivetrain' started by Ford_Forgotton, Apr 5, 2005.

  1. TEAMROPER59

    TEAMROPER59 SDD Junior Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Jul 26, 2009
    Location:
    santa rosa/california/usa
    what was the results, I have a 99 f-350 4x4 I drove over 500 miles, then the following weekend I had the same problem, Took the truck back to the Ford dealer, they cannot get
    the truck to run on the new cps, they contacted Ford which they want all the information for the truck, they installed a cps from Napa auto part, found the engine bucked 2 times. each time a check for fault codes, and find po344 last time this turned the service soon light in solid, this time the light did not turn
    on, as I did read po344 again, does anyone have any ideas, all the post that I have been reading, seems the latest cps work fine
    please help
    4-24-10 I just got my truck back from my local dealer, as the update cps would not work in my engine,
    after the dealership checked the end play on the cam, found there was to much clearance between the
    new updated cps, they replaced the engine (long block) at no charge, I had to pay to replace the water
    pump, hoses ect..I also had them replace the clutch, it's hard to believe, there was 141,000 miles on the
    engine.
     
    Last edited: Apr 25, 2010
  2. 6.0PSD777

    6.0PSD777 Full Access Member

    Messages:
    386
    Likes Received:
    0
    Joined:
    Nov 22, 2009
    Location:
    Mass
    $200? I just bought one from Ford for my buddies 97 and it cost $21.95
     
  3. Thomasam

    Thomasam ******

    Messages:
    1
    Likes Received:
    0
    Joined:
    Jan 8, 2012
    Location:
    hernando bch fla.
    Thanks

    I knew I was going toget my diesel mechanics education started evetually.
    My cps on my 97 E350 had been lingering for about a year, typical symptoms as learned on this forum,stalling at highway speeds sometimes lighting back up by itself sometimes not stalling at idle usually at red lights,stop signs etc. But always restarting and running normal until the next time.finally last night around 8:30 about a half a block into 5 mile smoke run/powerball run i learned that a full on cp$ failure does not put your 7.3 in limp mode it puts you in walk mode mode .I cannot imagine how many hours/days/weeks/dollars i could
    have spent without this forum. This foru;tum is my new religion.THANKS ALL:-;tu);tu
     
  4. DaveBen

    DaveBen SDD Senior Member

    Age:
    70
    Messages:
    9,539
    Likes Received:
    65
    Joined:
    May 31, 2005
    Location:
    Ukiah, California
    Many here carry a spare CPS just for that reason. It is cheap insurance.

    Dave
     
  5. GA_Boy

    GA_Boy SDD Junior Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jul 21, 2018
    Location:
    Jefferson, GA
    Hi, First Post. I read all 18 pages and obtained a wealth of information.
    I read yesterday about the magnet should be centered on the CPS. Here is a picture of one of mine.
    I guess I can remove the silicone and center the magnet and re-silicone.
    Any opinions are and will be appreciated.
    Thanks, Marvin
    EDIT AGAIN--------------After removing all the silicone it looks as if it can't be moved. Seems to be inside molded plastic.
    2001,F250, 7.3, Super duty
    [​IMG]
     

Share This Page