Talk about the 7.3L CPS Here!

Ford_Forgotton

Full Access Member
Joined
Apr 1, 2005
Messages
598
Reaction score
0
Location
***
Car_nut57 said:
I have been told that injector timing can be advanced by 4 degrees by installing a 1807339CXX CPS used for the DT466E International engine. Has anybody done this or know anything about it?

I read about that on TDS. Got into an argument with a guy about this. He claims the DT engine uses a weird tapered face that reads the timing disk differently. Said they use the 444e "powerstroke" sensor in bad running 466's to advance the timing.

Putting a DT sensor in a powerstroke would RETARD the timing. Which might be helpful if your running propane or your chip advances timing too much. Help prevent the BOOM of rods thru the block.
 

Mobeydick

Full Access Member
Joined
Jun 26, 2005
Messages
229
Reaction score
0
Location
Georgia
I have over 205,500 miles on my 7.3 with the CPS that came with it! I will be changing it Monday 6.27.05. My truck is shuddering some at 50/60 MPH. No codes in Mem. Don't know if this is causing the problem, I have already replaces the Speed Sensors and going to replace the TPS also!! Got the CPS from Powerstroke.com delivered for about $98.00!!
 
Last edited:

jvencius

Full Access Member
Joined
Apr 6, 2005
Messages
1,355
Reaction score
0
Location
In a van down by the river...
Thanks for the info--I went by the International dealer in town after work and picked up a spare CPS then went over to Sears to buy an appropriately-sized ratchet/extension/socket. Since Maggie and I will be on the road tomorrow through some pretty remote areas, where finding a tow truck might be tough, I'd rather ride around with ~$150 in spare parts in the glovebox that I don't need just to be on the safe side.
 

threejacks

Full Access Member
Joined
Jun 14, 2005
Messages
231
Reaction score
0
Location
South Central , KY
Mobeydick said:
I have over 205,500 miles on my 7.3 with the CPS that came with it! I will be changing it Monday 6.27.05. My truck is shuddering some at 50/60 MPH. No codes in Mem. Don't know if this is causing the problem, I have already replaces the Speed Sensors and going to replace the TPS also!! Got the CPS from Powerstroke.com delivered for about $98.00!!
What kind of shuddering do you have? Injectors can cause something like this.
 

probear

Whoresetmytitle?
Joined
Apr 1, 2005
Messages
27
Reaction score
0
Location
Gainesville/Cumming, GA
Mobeydick said:
I have over 205,500 miles on my 7.3 with the CPS that came with it! I will be changing it Monday 6.27.05. My truck is shuddering some at 50/60 MPH. No codes in Mem. Don't know if this is causing the problem, I have already replaces the Speed Sensors and going to replace the TPS also!! Got the CPS from Powerstroke.com delivered for about $98.00!!

A dirty IPR can and will cause a shutter. From what I understand, a CPS will either work or not work. I've had to clean my IPR a couple of times, and afterward, the truck runs great......
 

jlayne

Paint Sniffer
Joined
Apr 3, 2005
Messages
129
Reaction score
0
Location
Milledgeville, Ga
Mobeydick said:
I have over 205,500 miles on my 7.3 with the CPS that came with it! I will be changing it Monday 6.27.05. My truck is shuddering some at 50/60 MPH. No codes in Mem. Don't know if this is causing the problem, I have already replaces the Speed Sensors and going to replace the TPS also!! Got the CPS from Powerstroke.com delivered for about $98.00!!


my shudder like that kept getting worse untill it got weak enough it wouldn't pull the hat off your head.... it ended up being the injector harness (smoked my IDM as well but thats not usually the case)
 

Mobeydick

Full Access Member
Joined
Jun 26, 2005
Messages
229
Reaction score
0
Location
Georgia
While the Cruise Control is on, the truck feels like the T/C is unlocking and locking back up! Sometimes it will do it every mile or so then it will only do it every 50 miles or so. It is not related to Cruise Control because it will do it with out it on. It doesn't do it all the time!

What is an IPR?
 

Chewman

SDD Junior Member
Joined
Jul 7, 2005
Messages
47
Reaction score
1
Location
Michigan
I just had my 01 Excursion start a couple weeks back with an intermittent engine shut-off that would cause it to buck really hard like if you turned off the ignition on a gas vehicle. Late last week I finally got an SES with error code, and it was for the CPS. Changed it out over the weekend and the drive to work today was without a hitch.

I second "WHat's an IPR"? and how do you clean it?
 

Members online

No members online now.

Forum statistics

Threads
30,529
Messages
266,100
Members
14,639
Latest member
Jpmfl
Top